Ship to United Kingdom , USD

Reviews

webmaven 2018-03-25 00:02:07
I had trouble at first but this was my fault. If you are using any radio that is running OpenTX you need to make sure you download the proper firmware. You need to make sure your OpenTX firmware is downloaded with the "Multimodule" You can select this by going into the OpenTX Companion software click Settings and from the drop-down click settings again. In the window select "Multimodule". Keep See More
4
Recommendations (4)
Comments(0)
Satisfaction Survey

Download APP to get an exclusive 10% off coupon